SugarCRM Outlook connector V3 (2013 support) RC is now available

The RC of our latest (v3.0) SugarCRM connector for Outlook is now available.
This version has been re-written from the ground up to use SugarCRM's REST web service which replaces the old SOAP interface.

Some improvements to mention are....

- Support for Outlook 2010 and 2013 (2007 will be available soon)
- Use of SugarCRM's faster REST API
- Improved load times
- Improved record synchronisation (Batch processing means large quantities of records are no longer an issue)
- Improved manual archiving process
- New contextual search sidebar for faster archiving
- New UI
- Fixes for various issues that have plagued version 2.0 users.

Requirements....

- Outlook 2010/2013
- SugarCRM v6.2 or greater

You can download and install the new connector by clicking the link below.

http://goo.gl/lK78oD

Release notes

If you are having trouble installing the connector please make sure you first download and install the following two items from Microsoft.

http://www.microsoft.com/en-us/download/details.aspx?id=44074
http://www.microsoft.com/en-gb/download/details.aspx?id=30653

You will need to contact support[at]opacus.co.uk to request a new activation key for this version.

Please be aware that this is not the final release and bugs should be reported to our support address. (support[at]opacus.co.uk)


Comments

Plugin losing settings

Hi there,

the RC plugin loses its credentials, settings and even license information. We had that issue on several notebooks, Win 8.1, Office 2013. After restarting Outlook, all setting information are gone. I entered them eight to ten times, same result.

The users have admin rights. Is that behavior known and is there a workaround/solution for this issue?

Thank you.

Ingo

Thanks for your feedback,

Thanks for your feedback, this has now been fixed. Apologies for any issues this has caused you.

Plugin for Outlook 2013 having issues with adding new Leads/Cont

Hi,
I have installed the trial version to see if it is able to meet our needs.

the Plugin appears to install correctly and I can archive mail records. I cannot seem to add new records though. the log shows the following error:

2014-11-24 14:32:51.8513|FATAL|OSOP2013|Object reference not set to an instance of an object. trace: at OSOP2013.SCRMAPI.SugarRest.DeserializeModuleFields(String responseFromServer)

I have another user who tried it and connected first to a local suitecrm instance first then connected to the instance I am trying to connect to.

I have tried re-installing, disabling all other active Plugins, removing other email accounts but nothing seems to help.

Any other ideas that I might try?

thanks!

Problems installing

I am trying to install the RC of the Outlook client. I keep getting a 'the value of the property 'type' cannot be parsed' error message.

I have made sure I installed the prerequisites.

Archive to Projects

I can't seem to find a way to archive email to the projects module.

The self signed issue has now

The self signed issue has now been fixed

Can't wait to try it!

Thanks for the update. Looking forward to trying it as soon as the self-signed cert issue is resolved.

Post new comment

  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Lines and paragraphs break automatically.

More information about formatting options